Upgrade Java and SIMBL

16 Jan
I transferred my user account from Precious (a PowerPC mac) on Phoenix (an Intel mac), and when calling RDFPic (which needs Java), I got the following error:

java[1820] *** -[NSBundle load]: Error loading code /Library/InputManagers/SIMBL/SIMBL.bundle/Contents/MacOS/SIMBL for bundle /Library/InputManagers/SIMBL/SIMBL.bundle, error code 2 (link edit error code 0, error number 0 ())

The error didn’t prevent my photo RDFization, but I was bothered that there was the error in the first place.

I had the java version “1.5.0_06” (of maybe August 2005?) and found out on ACD that there had been a release on 12jan2007 for 1.5.0_07. I upgraded, but I got the SIMBL error anyway when calling RDFPic.

I located SIMBL stuff on my machine, but was none the wiser. I googled SIMBL.

SIMBL (Smart InputManager Bundle Loader) – pronounced like “symbol” or “cymbal” allows you to build hacks for Cocoa applications and apply the code selectively based on an application’s unique identifier.

I have no idea how SIMBL got installed on the Precious in the first place. But I installed the universal binary. And when I call RDFPic, not only does it keep working but also I don’t get the error message anymore.

If you look in your console.log (Applications/Utiliites/Console.app), and search “simbl”, you’ll see that a lot of applications use it and that a lot of errors are written.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: